Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 06, 2025 - 22:00 EST
Update
Maintenance is being re-scheduled for the following week at the same time, on February 6th.
Posted Jan 30, 2025 - 16:25 EST
Scheduled
We will be performing maintenance on Mindful Callback's US and LATAM voice infrastructure and Mindful Scheduler at this time. No downtime or caller impact is expected.
Posted Jan 23, 2025 - 16:30 EST
This scheduled maintenance affected: Mindful Callback Voice - Americas, US East, Mindful Callback Voice - Americas, US West, and Mindful Callback Voice - LATAM, São Paulo.