Mindful Insights and Mindful API - performance degradation

Incident Report for Mindful

Monitoring

Our 3rd party cloud provider has taken action to mitigate identified issues. While they continue to monitor services, our health metrics indicate that Scheduler Widgets and most of our API endpoints are now fully recovered and operational. Mindful Insights and historical data retrieval via APIs continue to experience service degradation as processing of data has been delayed. We will continue to monitor and provide updates as necessary to ensure to recovery of all Mindful services.
Posted Oct 20, 2025 - 20:28 EDT

Update

Our 3rd party cloud provider has observed signs of their services returning to a healthy state following latest mitigation actions. Mindful components such as APIs, Scheduler Widgets and Insights continue to experience service degradation as recovery steps take place. We will continue to monitor the situation and provide updates as necessary.
Posted Oct 20, 2025 - 14:35 EDT

Update

Due to ongoing platform provider issues, multiple Mindful services are experiencing degradation. This includes impacts now to Scheduler Widgets, which could impact the registration of calls within those channels. Users may continue to encounters service interruption to API endpoints and historical reporting within Insights. We will continue to monitor the situation and provide updates as necessary.
Posted Oct 20, 2025 - 11:53 EDT

Update

We have noticed an expanded outage that encompasses our API service which is impacting additional API endpoints. This has resulted in degradation to both Mindful Insights and Mindful API services. We will continue to monitor the situation and provide updates as necessary.
Posted Oct 20, 2025 - 10:55 EDT

Investigating

Our 3rd party cloud provider is experiencing service degradation which is causing Mindful's historical reporting and API services to be impacted. There is no data loss at this time, however, the processing of the data has been delayed. We will continue to monitor the situation and provide updates as necessary.
Posted Oct 20, 2025 - 09:49 EDT
This incident affects: Mindful Insights, Mindful API, Mindful Scheduler Widgets, and On-Premise Scheduler Widgets.