Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 05, 2024 - 22:00 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 05, 2024 - 13:42 EDT
Scheduled
We will be performing maintenance at this time. No downtime or caller impact is expected. Checkout the upcoming features and changes for this release in our release notes here.
NOTE: This maintenance does not impact clients using our legacy platform at callback.mindful.cx
Posted Aug 29, 2024 - 11:16 EDT
This scheduled maintenance affected: Mindful Callback Voice - Americas, US East, Mindful Callback Voice - Americas, US West, and Mindful Callback Voice - LATAM, São Paulo.