Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Feb 07, 2025 - 13:00 EST
Scheduled
We will be performing maintenance on Mindful Callback's EMEA and APAC voice infrastructure at this time. No downtime or caller impact is expected. This is the rescheduled maintenance from January 30th.
Posted Jan 30, 2025 - 16:27 EST
This scheduled maintenance affected: Mindful Callback Voice - EMEA, Frankfurt and Mindful Callback Voice - APAC, Sydney.