Scheduled maintenance is still in progress. We are extending the maintenance window a couple of hours in order to finish this. We'll post additional updates as needed.
Posted Sep 23, 2023 - 02:50 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 22, 2023 - 22:00 EDT
Scheduled
We will be performing scheduled maintenance at this time on all shared environments. Some downtime is expected during this maintenance window for clients that have migrated to our Spring '23 Release.
Posted Sep 14, 2023 - 22:08 EDT
This scheduled maintenance affected: Management Portal, Mindful Insights, Mindful API, Mindful Scheduler Widgets, On-Premise Scheduler Widgets, Notifications, Datastore, Mindful Callback Voice - Americas, US East, Mindful Callback Voice - Americas, US West, Mindful Callback Voice - LATAM, São Paulo, Mindful Callback Voice - EMEA, Frankfurt, and Mindful Callback Voice - APAC, Sydney.