Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 05, 2024 - 22:00 EST
Scheduled
We will be performing maintenance on Mindful Callback's US and LATAM voice infrastructure and Mindful Scheduler at this time. No downtime or caller impact is expected.
NOTE: This maintenance will be for clients using app.getmindful.com.
Posted Nov 22, 2024 - 14:24 EST
This scheduled maintenance affected: Mindful Scheduler Widgets, Mindful Callback Voice - Americas, US East, Mindful Callback Voice - Americas, US West, and Mindful Callback Voice - LATAM, São Paulo.