Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 17, 2024 - 22:00 EDT
Scheduled
We will be performing maintenance on Mindful Callback's US and LATAM voice infrastructure and Mindful Scheduler at this time. No downtime or caller impact is expected.
NOTE: This maintenance will be for all environments, callback.mindful.cx and app.getmindful.com.
Posted Oct 10, 2024 - 14:47 EDT
This scheduled maintenance affected: Mindful Scheduler Widgets, Mindful Callback Voice - Americas, US East, Mindful Callback Voice - Americas, US West, and Mindful Callback Voice - LATAM, São Paulo.