Verification is currently underway for the maintenance items.
Posted Sep 06, 2024 - 13:42 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 06, 2024 - 13:00 EDT
Scheduled
We will be performing maintenance at this time on our EMEA and APAC voice regions. No downtime or caller impact is expected. Checkout the upcoming features and changes for this release in our release notes here.
NOTE: This maintenance does not impact clients using our legacy platform at callback.mindful.cx
Posted Sep 05, 2024 - 13:41 EDT
This scheduled maintenance affected: Mindful Callback Voice - EMEA, Frankfurt and Mindful Callback Voice - APAC, Sydney.